maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jesse Farinacci <jie...@gmail.com>
Subject Re: WARNING: Cannot use Maven 3.0.3 with Maven Release Plugin 2.2.2 (MNG-5224)
Date Tue, 03 Jan 2012 20:58:27 GMT
Greetings,

On Tue, Jan 3, 2012 at 3:45 PM, Mark Derricutt <mark@talios.com> wrote:

> Surely something as egregious as allowing releases to break should block
> 3.0.4 from being released tho.  As someone who uses GPG in that manner for
> some of his releases I'd certainly want 3.0.4 to be able to release...


It didn't stop the 3.0.3 release, what's the difference with 3.0.4? It's
getting rather frustrating at seeing all these relatively solitary or
edge-case problems derail the entire release process.

I have performed many releases with 3.0.3 and 3.0.4-rcX both, so this is
not a problem for me, and I dare say it's a very large majority of users
that it is also not a problem for.

Stop stopping the presses, please!! It's just a stupid point release! It
doesn't have to solve every existing MNG-* out there! This kind of
localized Chicken Little behavior is making it harder and harder to get
small releases out the door. You're making it worse for all users.

*sigh*

(the same goes for all the bike shedding whiners about the dependency fetch
timeout - you know who you are)

-Jesse

-- 
There are 10 types of people in this world, those
that can read binary and those that can not.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message