maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: JDK 5 needed for Performing a Maven Project Release?
Date Thu, 12 Jan 2012 04:04:42 GMT

On 12/01/2012, at 2:08 PM, Barrie Treloar wrote:

> http://maven.apache.org/developers/release/maven-project-release-procedure.html
> says "you have JDK 5 installed and on your shell's path."

it should probably say "or above"...

> 
> I was about to try out the new laptop, which is a Macbook Air, and the
> is the first time I've used a Mac.
> It comes with JDK 6.
> 
> Are we happy that compiler options will correctly build JDK 5 classes?

Yep, as long as you used the right things, as you note next:

> (Things like http://docs.oracle.com/javase/6/docs/api/java/lang/String.html#isEmpty%28%29
> break binary backwards compatibility.)
> 
> Or do I need to work out how to install JDK 5?

Maven 3 has the animal sniffer plugin set up in its build - maybe that could be pushed up
to the parent. I think Jenkins runs all the plugins under JDK 5 so you could check that's
building fine first too.

- Brett

--
Brett Porter
brett@apache.org
http://brettporter.wordpress.com/
http://au.linkedin.com/in/brettporter
http://twitter.com/brettporter






---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message