maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simone Tripodi <simonetrip...@apache.org>
Subject Re: [site] custom elements in site.xml not merged
Date Mon, 17 Oct 2011 08:33:26 GMT
Thanks a lot for the hint Lukas, I'll give a try ASAP and let you know!
All the best,
SImo

http://people.apache.org/~simonetripodi/
http://simonetripodi.livejournal.com/
http://twitter.com/simonetripodi
http://www.99soft.org/



On Mon, Oct 17, 2011 at 8:57 AM, Lukas Theussl <ltheussl@apache.org> wrote:
>
> Hi Simone,
>
> The custom element is defined outside the body element, see
>
> http://maven.apache.org/doxia/doxia-sitetools/doxia-decoration-model/decoration.html
>
> so it should be referenced like $decoration.custom...
>
> HTH,
> -Lukas
>
>
> Simone Tripodi wrote:
>>
>> Hi Lukas!
>> I just added a new header in the Maven site[1] site.xml:
>>
>>   <custom>
>>     <head>
>>       <link rel="stylesheet" href="/css/site.css" type="text/css" />
>>     </head>
>>   </custom>
>>
>> Then in the skin I rendered in a comment all headers:
>>
>>     #if ( $decoration.body.head )
>>       <!-- $decoration.body.head -->
>>     #end
>>
>> when Looking at the generated page source, all I read is:
>>
>>           <!--<?xml version="1.0" encoding="UTF-8"?>
>> <head>
>>   <script src="http://www.google-analytics.com/urchin.js"
>> type="text/javascript"></script>
>>   <script type="text/javascript">_uacct =&quot;UA-140879-1&quot;;
>>         urchinTracker();</script>
>> </head>  -->
>>
>> that is the hint I got to write thet mail!
>> Thanks in advance for your help, have a nice WE!
>> Simo
>>
>> [1] http://svn.apache.org/repos/asf/maven/site/trunk
>>
>>
>> http://people.apache.org/~simonetripodi/
>> http://simonetripodi.livejournal.com/
>> http://twitter.com/simonetripodi
>> http://www.99soft.org/
>>
>>
>>
>> On Sat, Oct 15, 2011 at 6:16 PM, Lukas Theussl<ltheussl@apache.org>
>>  wrote:
>>>
>>> Looking at the source code of doxia's
>>> DefaultDecorationModelInheritanceAssembler, I would expect this to work.
>>> Can
>>> you provide a test project?
>>>
>>> -Lukas
>>>
>>>
>>> Simone Tripodi wrote:
>>>>
>>>> Hi again guys
>>>> I just figured out that if project B pom inherits from project A pom
>>>> which has attached the site descriptor with<custom>    elements,
in
>>>> project B the declared<custom>    elements are just ignored...
>>>> Is it a known bug or it is an issue to be filled?
>>>> Many thanks in advance, all the best!
>>>> Simo
>>>>
>>>> http://people.apache.org/~simonetripodi/
>>>> http://simonetripodi.livejournal.com/
>>>> http://twitter.com/simonetripodi
>>>> http://www.99soft.org/
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
>>>> For additional commands, e-mail: dev-help@maven.apache.org
>>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
>>> For additional commands, e-mail: dev-help@maven.apache.org
>>>
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
>> For additional commands, e-mail: dev-help@maven.apache.org
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message