maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Petr Janata" <petr.jan...@bcpraha.com>
Subject Re: Problems with register new archive type
Date Wed, 13 Jul 2011 06:47:16 GMT
I have worked around this issue by explicitly adding the plugin with custom packaging in dependencies
section of dependency plugin.
I do not know the exact cause of the issue.

<plugin>
	<!-- My tweaked axis2 plugin, declares aar packaging and un/archiver -->
	<groupId>org.apache.axis2</groupId>
	<artifactId>bc-axis2-aar-maven-plugin</artifactId>
	<version>1.5.4</version>
	<extensions>true</extensions>
<\plugin>

<plugin>
	<groupId>org.apache.maven.plugins</groupId>
	<artifactId>maven-dependency-plugin</artifactId>
	<executions>
		<execution>
			<goals>
				<goal>unpack-dependencies</goal>
			</goals>
			<phase>prepare-package</phase>
			<configuration>
				<includeTypes>aar</includeTypes>
				<outputDirectory>${project.build.directory}/aar</outputDirectory>
			</configuration>
		</execution>
	</executions>
	<dependencies>
		<!-- this plugin should be on classpath via earlier extension declaration,
			but it isn't, we need to name it separately -->
		<dependency>
			<groupId>org.apache.axis2</groupId>
			<artifactId>bc-axis2-aar-maven-plugin</artifactId>
			<version>1.5.4</version>
		</dependency>
	</dependencies>
</plugin>

Petr Janata

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message