maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Connolly <stephen.alan.conno...@gmail.com>
Subject Re: Move plexus dependencies to java 1.5 (Important!)
Date Thu, 09 Jun 2011 09:41:37 GMT
Will this affect toolchains from using the older javac and running
tests with older jvms?

toolchains is the recommended way to compile with older java versions
and run tests with older java versions...

I see no reason, as long as toolchains based invoking of older java
versions is not affected, with moving our runtime requirement up to
java 1.5

-Stephen

On 9 June 2011 10:30, Kristian Rosenvold <kristian.rosenvold@gmail.com> wrote:
> I'd like to gradually start migrating some of these to java 1.5. Doing
> so will effectively prevent any java 1.4 clients from upgrading.
>
> It's my opinion that this move will effectively be the end of java all
> 1.4 support. (The surefire fork is the only "declared" java 1.3/1.4 (!)
> support left that I am aware of but this part of surefire does not have
> any plexus dependencies, and I think even that might go eventually.)
>
> Since these projects are technically not ASF, this is not a vote as
> such. But it's definitely time to speak up on 1.4 support if you have
> opinions.
>
>
> Kristian
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message