maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jamie Townsend <jtown...@progress.com>
Subject Re: DefaultPluginManager.executeMojo not supported with Maven 3?
Date Wed, 02 Jun 2010 19:15:09 GMT
So if we're happy to not use Maven 3 until the 3.0 release, the old API will be working again?

--
Jamie


> No, you'll have to adjust to the new API. We are striving to be compatible from
> the CLI perspective. We'll have a new method published for the 3.0 release.
>
> On Jun 2, 2010, at 8:21 AM, Jamie Townsend wrote:
>
> > I'm trying to get http://code.google.com/p/mojo-executor/ to work with Maven
> > 3, but I'm running into an UnsupportedOperationExecption coming from
> > DefaultPluginManager.executeMojo.
> >
> > I've had a look at both the maven-sonar-plugin & maven-cli-plugin approaches
> > to solving this issue, but as far as I can tell, those solutions are not
> > backwards compatible.  Is there a backwards compatible way to achieve this?
> >
> > TIA,
> > Jamie
>
> Thanks,
>
> Jason
>
> ----------------------------------------------------------
> Jason van Zyl
> Founder,  Apache Maven
> http://twitter.com/jvanzyl
> ---------------------------------------------------------
>
> A language that doesn't affect the way you think about programming is not worth
> knowing.
>
>  -- Alan Perlis

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message