maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kristian Rosenvold <kristian.rosenv...@gmail.com>
Subject Surefire staying 1.3 compatible, SUREFIRE-621
Date Tue, 15 Jun 2010 16:29:15 GMT
I looked at this issue, and it seems to me like plexus-utils lost its
1.3 compatibility between 1.5.6 and 1.5.7. Not so long ago someone
declared plexus-utils 1.4, IMO a fairly sensible thing to do given the
state of affairs.

The only practical way I see of solving this stuff is to steal the
necessary parts of StringUtils into surefire. I tried this and it seems
to do the trick. There is still a dependency upon (the now 1.4)
plexus-utils, which might not be sustainable but at least works.

Unless someone has a better suggestion I'll solve 621 this way.

Kristian



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message