maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From eyal edri <eyal.e...@gmail.com>
Subject getting null in manifest when using <classpathLayoutType>custom</classpathLayoutType>
Date Sun, 07 Mar 2010 15:14:28 GMT
Hello,

i don't know if this a bug or a misuse of the archiver.

when using a custom layout in manifest, i get 'null' for every value i use:

<build>
  <plugins>
      <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-jar-plugin</artifactId>
        <configuration>
          <archive>
            <!-- define class path and main class -->
            <manifest>
              <addClasspath>true</addClasspath>

 <mainClass>${project.groupId}.${project.artifactId}</mainClass>
              <classpathLayoutType>custom</classpathLayoutType>

 <customClasspathLayout>/usr/lib/ctch/java/${artifact.groupIdPath}/${artifact.artifactId}</customClasspathLayout>
            </manifest>
          </archive>
        </configuration>
      </plugin>
   </plugins>
 </build>

the manifest.mf:

Manifest-Version: 1.0
Archiver-Version: Plexus Archiver
Created-By: Apache Maven
Built-By: eyale
Build-Jdk: 1.6.0_18
Main-Class: com.commtouch.url.unknowns.IncreasePriority
Class-Path: /usr/lib/ctch/java/null/null /usr/lib/ctch/java/null/null
 /usr/lib/ctch/java/null/null /usr/lib/ctch/java/null/null /usr/lib/ct
 ch/java/null/null



-- 
Eyal Edri

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message