maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kurt Zettel <kurt.zet...@metova.com>
Subject Javadoc plugin issues with custom plugin
Date Thu, 11 Feb 2010 13:02:43 GMT
I am now having similar problems with the Javadoc plugin.  It works with
Maven 2.2.1 but with Maven 3 it cannot resolve my custom package types.
 Each project runs fine individually but when I try to do a multi-module
build it cannot resolve the dependencies because it does not use my artifact
handler.

On Wed, Jan 27, 2010 at 1:04 PM, Brett Porter <brett@apache.org> wrote:

> Try the latest 2.0-SNAPSHOT of the plugin, this should be fixed now.
>
> - Brett
>
> On 28/01/2010, at 4:29 AM, Kurt Zettel wrote:
>
> > I developed a plugin and integration tested it using using Maven 3.  One
> of
> > the things it provides is a custom packaging type and an artifact handler
> > for the packaging type.  It also has its own lifecycle.  I can build and
> > deploy projects using the plugin without any problems. I am having an odd
> > problem when I try to use the Maven release plugin on a multi-module
> build.
> > The install of the root pom is failing because of missing dependencies.
>  It
> > is telling me I have missing artifacts but the missing artifacts are part
> of
> > the multi-module build.  I am using version 2.0-beta-9 of the release
> plugin
> > (which worked fine with Maven 2.2.1) but it is giving me problems with
> Maven
> > 3.0 alpha 6.  Any advice on where to look in the code to fix this
> problem?
> >
> > Thank you,
> > Kurt Zettel
>
> --
> Brett Porter
> brett@apache.org
> http://brettporter.wordpress.com/
>
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message