maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: webapp sources directory does not exist - skipping.
Date Mon, 08 Feb 2010 01:26:20 GMT
users@maven.apache.org is the appropriate list for these questions.

Thanks,
Brett

On 07/02/2010, at 1:35 PM, noobnoob wrote:

> 
> Hi,
> 
> I am new to Maven, I created a project using the Wicket quickstart
> archetype. I am on Ubuntu 9.10.
> I could not get mvn release:perform to run and I suspect the cause might be
> the release plugin.
> 
> mvn war:war works fine. And there is a web.xml in src/main/webapp/WEB-INF/
> 
> mvn release:perform -X yields
> ...
> [INFO] [DEBUG] Configuring mojo
> 'org.apache.maven.plugins:maven-war-plugin:2.1-beta-1:war' -->                   
                                                                                 
> [INFO] [DEBUG]   (s) archiveClasses = false                                         
                                                                                         
                    
> [INFO] [DEBUG]   (s) attachClasses = false                                          
                                                                                         
                    
> [INFO] [DEBUG]   (s) cacheFile =
> /home/.../work/workspace-maven/jskrupel/target/checkout/target/war/work/webapp-cache.xml
                                                                    
> [INFO] [DEBUG]   (s) classesClassifier = classes                                    
                                                                                         
                    
> [INFO] [DEBUG]   (s) classesDirectory =
> /home/.../work/workspace-maven/jskrupel/target/checkout/target/classes              
                                                                 
> [INFO] [DEBUG]   (f) escapedBackslashesInFilePath = false                           
                                                                                         
                    
> [INFO] [DEBUG]   (s) failOnMissingWebXml = true                                     
                                                                                         
                    
> [INFO] [DEBUG]   (f) filteringDeploymentDescriptors = false                         
                                                                                         
                    
> [INFO] [DEBUG]   (s) outputDirectory =
> /home/.../work/workspace-maven/jskrupel/target/checkout/target                      
                                                                  
> [INFO] [DEBUG]   (s) primaryArtifact = true                                         
                                                                                         
                    
> [INFO] [DEBUG]   (s) project = MavenProject: com.jskrupel:jskrupel:0.0.4 @
> /home/.../work/workspace-maven/jskrupel/target/checkout/pom.xml                     
                              
> [INFO] [DEBUG]   (f) session =
> org.apache.maven.execution.MavenSession@33b121                                      
                                                                               
> [INFO] [DEBUG]   (s) useCache = true                                                
                                                                                         
                    
> [INFO] [DEBUG]   (s) warName = jskrupel-0.0.4                                       
                                                                                         
                    
> [INFO] [DEBUG]   (s) warSourceDirectory =
> /home/.../work/workspace-maven/jskrupel/target/checkout/src/main/webapp             
                                                               
> [INFO] [DEBUG]   (s) webappDirectory =
> /home/.../work/workspace-maven/jskrupel/target/checkout/target/jskrupel-0.0.4       
                                                                  
> [INFO] [DEBUG]   (s) workDirectory =
> /home/.../work/workspace-maven/jskrupel/target/checkout/target/war/work             
                                                                    
> [INFO] [DEBUG] -- end configuration -- 
> [INFO] [INFO] [war:war {execution: default-war}] 
> ...
> [INFO] [INFO] Processing war project                                                
                                                                                         
                    
> [INFO] [DEBUG] webapp sources directory does not exist - skipping.                  
                                                                                         
                    
> [INFO] [DEBUG] Dump of the current build pathSet content -->                     
                                                                                         
                       
> [INFO] [DEBUG] -- end of dump --                             
> ...
> [INFO] [DEBUG] Excluding [] from the generated webapp archive.                      
                                                                                         
                    
> [INFO] [DEBUG] Including [**] in the generated webapp archive.                      
                                                                                         
                    
> [INFO] [INFO] Building war:
> /home/thibault/work/workspace-maven/jskrupel/target/checkout/target/jskrupel-0.0.4.war
                                                                                
> [INFO] [INFO]
> ------------------------------------------------------------------------            
                                                                                         
      
> [INFO] [ERROR] BUILD ERROR                                                          
                                                                                         
                    
> [INFO] [INFO]
> ------------------------------------------------------------------------            
                                                                                         
      
> [INFO] [INFO] Error assembling WAR: webxml attribute is required (or
> pre-existing WEB-INF/web.xml if executing in update mode)
> 
> I googled the error and tried changing the release-war configuration.
> However, it seems that the war plugin part of the pom.xml is ignored when
> calling mvn release:perform
> 
> Notice "webapp sources directory does not exist - skipping." even though it
> exists and works with mvn war:war
> 
> When I call mvn war:war, I see all changes I make, such as choosing a
> different war plugin version, or changing the webXml or failOnMissingWebXml,
> but mvn release:perform always uses version 2.1-beta-1 and always the same
> configs, regardless of the pom.
> 
> I tried with release plugin 2.0-beta-9 and 2.0-beta-8.
> 
> The reason I blame the release plugin and not the war plugin is that when I
> try  mvn war:war -X with war plugin 2.1-beta-1, it works fine, the pom
> configs are read and the web.xml is found and copied.
> -- 
> View this message in context: http://old.nabble.com/webapp-sources-directory-does-not-exist---skipping.-tp27485343p27485343.html
> Sent from the Maven Developers mailing list archive at Nabble.com.
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
> 

--
Brett Porter
brett@apache.org
http://brettporter.wordpress.com/





---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message