maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From noobnoob <>
Subject webapp sources directory does not exist - skipping.
Date Sun, 07 Feb 2010 02:35:06 GMT


I am new to Maven, I created a project using the Wicket quickstart
archetype. I am on Ubuntu 9.10.
I could not get mvn release:perform to run and I suspect the cause might be
the release plugin.

mvn war:war works fine. And there is a web.xml in src/main/webapp/WEB-INF/

mvn release:perform -X yields
[INFO] [DEBUG] Configuring mojo
'org.apache.maven.plugins:maven-war-plugin:2.1-beta-1:war' -->                        
[INFO] [DEBUG]   (s) archiveClasses = false                                              
[INFO] [DEBUG]   (s) attachClasses = false                                               
[INFO] [DEBUG]   (s) cacheFile =
[INFO] [DEBUG]   (s) classesClassifier = classes                                         
[INFO] [DEBUG]   (s) classesDirectory =
[INFO] [DEBUG]   (f) escapedBackslashesInFilePath = false                                
[INFO] [DEBUG]   (s) failOnMissingWebXml = true                                          
[INFO] [DEBUG]   (f) filteringDeploymentDescriptors = false                              
[INFO] [DEBUG]   (s) outputDirectory =
[INFO] [DEBUG]   (s) primaryArtifact = true                                              
[INFO] [DEBUG]   (s) project = MavenProject: com.jskrupel:jskrupel:0.0.4 @
[INFO] [DEBUG]   (f) session =
[INFO] [DEBUG]   (s) useCache = true                                                     
[INFO] [DEBUG]   (s) warName = jskrupel-0.0.4                                            
[INFO] [DEBUG]   (s) warSourceDirectory =
[INFO] [DEBUG]   (s) webappDirectory =
[INFO] [DEBUG]   (s) workDirectory =
[INFO] [DEBUG] -- end configuration -- 
[INFO] [INFO] [war:war {execution: default-war}] 
[INFO] [INFO] Processing war project                                                     
[INFO] [DEBUG] webapp sources directory does not exist - skipping.                       
[INFO] [DEBUG] Dump of the current build pathSet content -->                          
[INFO] [DEBUG] -- end of dump --                             
[INFO] [DEBUG] Excluding [] from the generated webapp archive.                           
[INFO] [DEBUG] Including [**] in the generated webapp archive.                           
[INFO] [INFO] Building war:
[INFO] [ERROR] BUILD ERROR                                                               
[INFO] [INFO] Error assembling WAR: webxml attribute is required (or
pre-existing WEB-INF/web.xml if executing in update mode)

I googled the error and tried changing the release-war configuration.
However, it seems that the war plugin part of the pom.xml is ignored when
calling mvn release:perform

Notice "webapp sources directory does not exist - skipping." even though it
exists and works with mvn war:war

When I call mvn war:war, I see all changes I make, such as choosing a
different war plugin version, or changing the webXml or failOnMissingWebXml,
but mvn release:perform always uses version 2.1-beta-1 and always the same
configs, regardless of the pom.

I tried with release plugin 2.0-beta-9 and 2.0-beta-8.

The reason I blame the release plugin and not the war plugin is that when I
try  mvn war:war -X with war plugin 2.1-beta-1, it works fine, the pom
configs are read and the web.xml is found and copied.
View this message in context:
Sent from the Maven Developers mailing list archive at

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message