maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arnaud HERITIER <arnaud.herit...@exoplatform.com>
Subject Re: Java version to release
Date Fri, 14 Aug 2009 09:53:04 GMT
Thx to Stephane Nicoll who pointed me on the problem.The last bullet in
prerequisites says that we can use maven 2.2, but it is false because we
cannot use it to release plugins or shared components. I didn't understand
that it was maven which didn't want to start.
I have to come back to maven 2.0.10 for the release.

Cheers,

Arnaud

# Arnaud Héritier
# Software Factory Manager
# eXo Platform
# http://www.exoplatform.com
# http://blog.aheritier.net


On Fri, Aug 14, 2009 at 11:39 AM, Arnaud HERITIER <
arnaud.heritier@exoplatform.com> wrote:

> Hi,
>   I'm releasing a shared component (maven-common-artifact-filter) and I'm
> following our guide (
> http://maven.apache.org/developers/release/releasing.html) which says to
> use java 1.4.
>   When I launch the release:prepare goal I receive the error :
> Java specification version: 1.4
> This release of Maven requires Java version 1.5 or greater.
>
>   Even if maven core 2.2 is compatible with Java 1.5+, I think that our
> plugins and shared components have to continue to be compatible with 1.4 to
> be used in/with maven 2.0.X ?
>
> Cheers,
>
> Arnaud
>
> # Arnaud Héritier
> # Software Factory Manager
> # eXo Platform
> # http://www.exoplatform.com
> # http://blog.aheritier.net
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message