maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul MERLIN <p...@nosphere.org>
Subject Re: Can system locale change release:prepare behavior ?
Date Tue, 05 May 2009 17:21:23 GMT
Thanks,

I've tried with a svn:// url without any problem (releasing & branching).

/Paul


Le mardi 05 mai 2009 11:41:15, Olivier Lamy a écrit :
> Hi,
> There is an implementation of svn only in java (using svnkit) which is
> available here [1].
>
> You can use that with adding a dependency in the maven-release-plugin :
>
>     <dependency>
>       <groupId>com.google.code.maven-scm-provider-svnjava</groupId>
>       <artifactId>maven-scm-provider-svnjava</artifactId>
>       <version>1.4</version>
>     </dependency>
>
> I have tested this with changing my scm url to scm:javasvn:
> Or (but I have not tested this ) adding the following configuration in
> the release mojo :
>
>               <providerImplementations>
>                 <svn>javasvn</svn>
>               </providerImplementations>
>
> HTH,
> --
> Olivier
>
> [1] http://code.google.com/p/maven-scm-provider-svnjava/
>
> 2009/5/4 Paul MERLIN <paul@nosphere.org>:
> > Hey,
> >
> > I'm facing weird problems with the maven-release-plugin and friends.
> > I use maven-release-plugin-2.0-beta-9 and get the same results with
> > either maven 2.1.0 or 2.2.0-RC1.
> > I tried with two subversion clients with the same results too : 1.4.6 and
> > 1.6.1.
> >
> >
> > I'm issuing the following instruction :
> >
> > mvn -B clean release:prepare -DreleaseVersion=0.4.0 -
> > DdevelopmentVersion=0.5.0-SNAPSHOT
> >
> >
> >
> > I'm getting the following error (full execution log is attached to this
> > email):
> >
> >
> > [INFO]
> > ------------------------------------------------------------------------
> > [ERROR] BUILD FAILURE
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Unable to tag SCM
> > Provider message:
> > The svn tag command failed.
> > Command output:
> > svn: Impossible de trouver la localisation dans le dépôt de
> > 'svn://acme.net/trunk/ekPom' pour la révision 0
> >
> >
> >
> > So, a little bit upset I tried bizarre things and found something
> > interesting, IOW: back to roots :)
> >
> > My default locale is fr_FR.UTF-8, if I use LC_ALL as C or en_US.UTF-8
> > everything is working as expected !!
> >
> >
> > What do you think ?
> >
> > /Paul
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> > For additional commands, e-mail: dev-help@maven.apache.org
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message