maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wendy Smoak <wsm...@gmail.com>
Subject Re: 2.2.0 and JDK 1.5
Date Thu, 30 Apr 2009 04:05:54 GMT
On Wed, Apr 29, 2009 at 8:23 PM, John Casey <jdcasey@commonjava.org> wrote:

> Assuming we require JDK 1.5 for Maven 2.2.0, I don't know how to tell users
> to build projects that require JDK 1.4, using a JDK 1.4 compiler. From what
> I've been able to find, the toolchains stuff isn't used by any released
> plugin versions, which means we'd have to release these plugins before we
> could support that use case in a 2.2.0/1.5+ world.
>
> Can somebody please help me out with this? How do we support the 1.4 use
> case if we require JDK 1.5+ in Maven itself?

It's possible now, but ugly...
http://maven.apache.org/plugins/maven-compiler-plugin/examples/compile-using-different-jdk.html

I'd guess those users will want to stay on 2.0 or 2.1 until the rest
of the toolchains work comes through.

-- 
Wendy

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message