maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Casey <jdca...@commonjava.org>
Subject 2.2.0 and JDK 1.5
Date Thu, 30 Apr 2009 03:23:33 GMT
I just had a disquieting thought:

Assuming we require JDK 1.5 for Maven 2.2.0, I don't know how to tell 
users to build projects that require JDK 1.4, using a JDK 1.4 compiler. 
 From what I've been able to find, the toolchains stuff isn't used by 
any released plugin versions, which means we'd have to release these 
plugins before we could support that use case in a 2.2.0/1.5+ world.

Can somebody please help me out with this? How do we support the 1.4 use 
case if we require JDK 1.5+ in Maven itself?

Thanks,

-john

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message