maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: XWiki builds was: [vote] Maven 2.1.0
Date Fri, 20 Mar 2009 13:22:05 GMT

On 20/03/2009, at 6:55 PM, Brett Porter wrote:

>
> It is missing the -sources JAR for the GWT project before it.
>
> But this is a little weird...
> 1) built in the same directory, the sources JAR is added to the  
> classpath list, as is the main one
> 2) built in the reactor, it is not added to the classpath list and  
> fails
> 3) in 2.1.0-M1 built in the reactor, it is still not added to the  
> classpath list, but succeeds in finding it somehow.
>
> I'm checking the GWT plugin source code.

Confirmed this occurred in MNG-4056 (r749612) - rolling it back has  
the build pass again.

However, I consider this a bug in the GWT plugin, it is using  
getCompileClasspathElements(), and expecting to get back the source  
JAR. Source JARs are not meant to be on the classpath - however before  
the above fix they were if you used the classifier/extension combo. A  
simple fix in the GWT plugin fixes the problem without changing the  
Maven release. I filed this with the project [1].

I'll update the release notes to make this clear.

Cheers,
Brett

[1] http://code.google.com/p/gwt-maven/issues/detail?id=200

--
Brett Porter
brett@apache.org
http://blogs.exist.com/bporter/


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message