maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Lamy <ol...@apache.org>
Subject Re: Committers JDK version for releasing plugins.
Date Sat, 21 Mar 2009 14:51:11 GMT
Personnally, I have always used a 1.4 jdk (and always use 1.4) to
cut/build a maven stuff release.
You can get one here http://java.sun.com/j2se/1.4.2/download.html
Note the EOSL of the 1.4 this means you have to be regitered to get
this old and not any more supported java version.

--
Olivier


2009/3/20 Stephen Connolly <stephen.alan.connolly@gmail.com>:
> You'd need to use animal sniffer to ensure that you're not using 1.5 or 1.6
> only methods (e.g. String.isEmpty(), etc)
>
> 2009/3/20 Barrie Treloar <baerrach@gmail.com>
>
>> I vaguely remember that 1.4 should be used but I can't find anything
>> on Committer Environment or Committer Settings.
>>
>> Does that mean the compiler settings configured in the parent poms is
>> good enough?
>>
>> My machine recently went boom so I have re-installed and I only have
>> JDK 1.6.0_11.
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
>> For additional commands, e-mail: dev-help@maven.apache.org
>>
>>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message