maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: XWiki builds was: [vote] Maven 2.1.0
Date Fri, 20 Mar 2009 07:55:53 GMT

On 20/03/2009, at 5:42 PM, Brett Porter wrote:

>
> On 20/03/2009, at 1:36 PM, Brett Porter wrote:
>
>>
>> On 19/03/2009, at 8:03 PM, Vincent Massol wrote:
>>
>>> It's failing for XWiki's build...
>>> Are you still running XWiki's build  on your hudson ci btw?
>>>
>>> It's failing with the gwt maven plugin.
>>>
>>> It works fine with 2.1.0-M1 though. Ping me if you need help to  
>>> reproduce it.
>>>
>>
>>
>> Can we get the error message? Like John, it's taking me a while to  
>> chase all the dependencies in weird locations to attempt the build.
>>
>
>
> Ok, got through the build with 2.1.0-M1.
>
> Got this error on 2.1.0 that is not there in 2.1.0-M1:
>
> Removing units with errors
>   [ERROR] Errors in 'file:/Users/brett/scm/xwiki/web/wysiwyg/src/ 
> main/java/com/xpn/xwiki/wysiwyg/client/WysiwygService.java'
>      [ERROR] Line 138: No source code is available for type  
> com.xpn.xwiki.gwt.api.client.XWikiGWTException; did you forget to  
> inherit a required module?
> [...]
> Removing invalidated units
>   [WARN] Compilation unit 'file:/Users/brett/scm/xwiki/web/wysiwyg/ 
> src/main/java/com/xpn/xwiki/wysiwyg/client/plugin/link/ui/ 
> AbstractWikiPageLinkTab.java' is removed due to invalid reference(s):
>      [WARN] file:/Users/brett/scm/xwiki/web/wysiwyg/src/main/java/ 
> com/xpn/xwiki/wysiwyg/client/WysiwygService.java
> [...]
>
> Is that it?
>
> However, running from within the directory, it works - it's only in  
> the reactor (either the whole lot, or just from the web directory)  
> where it fails. Running with -f from the web directory works, so I  
> suspect this is reactor related, not path adjustment related.
>
> So, I've narrowed it down - now taking a closer look.
>


It is missing the -sources JAR for the GWT project before it.

But this is a little weird...
1) built in the same directory, the sources JAR is added to the  
classpath list, as is the main one
2) built in the reactor, it is not added to the classpath list and fails
3) in 2.1.0-M1 built in the reactor, it is still not added to the  
classpath list, but succeeds in finding it somehow.

I'm checking the GWT plugin source code.

- Brett

--
Brett Porter
brett@apache.org
http://blogs.exist.com/bporter/


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message