maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Benedict <pbened...@apache.org>
Subject Re: JDK ranges
Date Thu, 05 Feb 2009 06:54:19 GMT
I support only ranges. The + notation is just shorthand, but why allow
2 ways to do the same thing?

Paul

On Wed, Feb 4, 2009 at 10:41 PM, Brian E. Fox <brianf@reply.infinity.nu> wrote:
> Yep. In the context of the enforcer this was most natural, since you
> would normally say "enforcer jdk is at least 1.5" etc.
>
> -----Original Message-----
> From: Brett Porter [mailto:brett@apache.org]
> Sent: Wednesday, February 04, 2009 11:28 PM
> To: Maven Developers List
> Subject: Re: JDK ranges
>
> Ah, I misread it. I thought 1.4 was [1.4,1.5) in the enforcer (Which
> is how it works in the profiles).
>
> - Brett
>
> On 05/02/2009, at 3:15 PM, Brian E. Fox wrote:
>
>> Just a clarification, the enforcer impl treats "1.4" as 1.4+ or more
>> literally [1.4,). This slightly overrides the version range internally
>> because in that case "1.4" = (,) with a recommended version of 1.4.
>>
>>
>>
>> -----Original Message-----
>> From: Brett Porter [mailto:brett@apache.org]
>> Sent: Wednesday, February 04, 2009 6:26 PM
>> To: Maven Developers List
>> Subject: JDK ranges
>>
>> Hi,
>>
>> First of all, kudos to Benjamin for knocking out my latest issues IT
>> while I slept (I hear he is actually capable of knocking them out in
>> his sleep :)
>>
>> Due to an interesting change history (closed for 2.0.x, which I
>> assumed to be the latest release 2.0.7, but was actually trunk), I
>> missed 1910 as having been done on trunk already - thanks again to
>> Benjamin for picking it up.
>>
>> We now have a conflicting syntax on trunk and 2.1.x - one is "1.4+",
>> the other "[1.4,)".
>>
>> I'd like to align them - does anyone have preferences for the
>> following options?
>>
>> (a) support both
>> (b) support only +
>> (c) support only ranges [,]; (,); etc
>>
>> I'd prefer to support only one, and as the Enforcer is well
>> established and using (c) [1]; I'd like to suggest we also adopt that
>> and drop support for "1.4+".
>>
>> Cheers,
>> Brett
>>
>> [1] http://maven.apache.org/enforcer/enforcer-rules/versionRanges.html
>>
>> --
>> Brett Porter
>> brett@apache.org
>> http://blogs.exist.com/bporter/
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
>> For additional commands, e-mail: dev-help@maven.apache.org
>>
>
> --
> Brett Porter
> brett@apache.org
> http://blogs.exist.com/bporter/
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message