maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Costin Caraivan <ccarai...@axway.com>
Subject Re: Map @parameter loading problem
Date Fri, 06 Feb 2009 13:21:15 GMT


Benjamin Bentmann wrote:
> 
> Costin Caraivan wrote:
> 
>> By the way, this works when I move the <configuration> section in the
>> root
>> of the plugin.
> 
> We have a (passing) IT [0] to test <execution> configuration which 
> includes a Map parameter so I wonder how do you invoke your mojo in the 
> first place? From the command line? Per <execution> configurations have 
> by design no effect to CLI invocations of a plugin, they are only meant 
> for executions bound to the build lifecycle.
> 
> Benjamin
> 
> [0] 
> http://svn.eu.apache.org/repos/asf/maven/core-integration-testing/trunk/core-it-suite/src/test/resources/mng-3864/pom.xml
> 


The invocation is from the pom.xml, inside a profile. So execution bound to
a build lifecycle. Here is the execution (out of which I took out the
<configuration> section for now.
<execution>
<id>unpack-plugins</id>
<phase>process-resources</phase>
<goals>
<goal>unpackPlugins</goal>
</goals>
</execution>
-- 
View this message in context: http://www.nabble.com/Map-%40parameter-loading-problem-tp21854211p21872258.html
Sent from the Maven Developers mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message