maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arnaud HERITIER" <aherit...@gmail.com>
Subject Re: How to support modelVersion > 4.0.0
Date Tue, 25 Nov 2008 22:59:03 GMT
Thus when spring, hibernate, whatever will decide to publish their poms in a
4.0.0+ format projects which will want to use those new version will have to
upgrade maven too. I think that in many corporate environment their managers
will just say ... no (too risky, expensive, ..). And those frameworks we'll
have the pressure of their users to continue to publish their artifact with
4.0.0 poms.
We have already a lot of difficuties to try to have as many users as
possible using our latest "bug fix" 2.0.9... (for many reasons ..)

Arnaud

On Tue, Nov 25, 2008 at 11:45 PM, Paul Benedict <pbenedict@apache.org>wrote:

> I just don't see the big deal with forcing users to upgrade Maven if
> they want to use a newer POM version. It will be up to the publishers
> to decide whether they want 4.0, 4.1, or both formats in the
> repository. Let the free market decide what should be supported.
>
> Paul
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
>
>


-- 
..........................................................
Arnaud HERITIER
12 guidelines to boost your productivity with a Java software factory -
http://tinyurl.com/56s9tw
..........................................................
OCTO Technology - aheritier AT octo DOT com
www.octo.com | blog.octo.com
..........................................................
ASF - aheritier AT apache DOT org
www.apache.org | maven.apache.org
...........................................................

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message