maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arnaud HERITIER" <aherit...@gmail.com>
Subject Re: [eclipse-plugin] java 1.5
Date Mon, 24 Nov 2008 10:34:33 GMT
No, our plugins have to be compatible with java 1.4 (which is the current
java version supported by maven 2.0.X).
Be careful to not use 1.5 APIs and syntax in your patch.

Arnaud

On Sun, Nov 23, 2008 at 8:17 PM, Andreas Höhmann <
andreas.hoehmann@hora-obscura.de> wrote:

> Hello folks,
>
> can we add a
>
>      <plugin>
>        <groupId>org.apache.maven.plugins</groupId>
>        <artifactId>maven-compiler-plugin</artifactId>
>        <configuration>
>          <source>1.5</source>
>          <target>1.5</target>
>        </configuration>
>      </plugin>
>
> to the pom of maven-eclipse-plugin (2.6-SNAPSHOT: trunk).
>
> Currently im fixing the bug http://jira.codehaus.org/browse/MECLIPSE-273
> and i want use java 1.5 features (generics etc.). Is this possible or not
> (for backward compatibility)?
>
> regards
> höhmi
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
>
>


-- 
..........................................................
Arnaud HERITIER
12 guidelines to boost your productivity with a Java software factory -
http://tinyurl.com/56s9tw
..........................................................
OCTO Technology - aheritier AT octo DOT com
www.octo.com | blog.octo.com
..........................................................
ASF - aheritier AT apache DOT org
www.apache.org | maven.apache.org
...........................................................

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message