maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject plugin versions in super POM and future releases
Date Wed, 09 Apr 2008 03:54:17 GMT
Hi,

I was wondering if anyone had opinions about what happens in 2.0.10,  
2.1, etc with the versions of plugins that are now specified in the  
super POM.

My gut feeling is that we should not upgrade these without a change to  
the modelVersion - the POM should be the sole reference for build  
behaviour and while I accept that changing the version of Maven can  
bring some behavioural differences this would be the most significant.  
On the other hand, we wouldn't want to perpetuate forever bugs that  
might be in the plugins (especially those that are a bit newer and  
labelled alpha/beta).

I think our default stance from here on should be to make no  
modifications to the super POM without bumping the modelVersion, but  
reserve the right to make exceptions if the case arises.

How do others feel about this?

Cheers,
Brett

--
Brett Porter
brett@apache.org
http://blogs.exist.com/bporter/


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message