maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bley <stefan.b...@saxsys.de>
Subject Re: [VOTE] Release Maven Eclipse plugin version 2.5.1
Date Fri, 04 Apr 2008 19:30:47 GMT
I would like to vote for it. How do I do this?

Stefan

Arnaud HERITIER schrieb:
> Actually I have only :
> 1 PMC  : myself
> 1 Committer  : Nicolas DE LOOF
> 1 User : Richard VAN NIEUWENHOVEN
>
> Anyone else ? (I'm already working on 2.5.2 ;-) )
>
> Arnaud
>
> On Fri, Apr 4, 2008 at 12:39 AM, Arnaud HERITIER <aheritier@gmail.com> wrote:
>   
>> I have not enough PMCs votes to launch the release. If some of you can test it.
>>  thx
>>
>>  cheers
>>
>>  arnaud
>>
>>
>>
>>  On Thu, Apr 3, 2008 at 4:27 PM, Brian E. Fox <brianf@reply.infinity.nu> wrote:
>>  > Ok that's right. The prerequisite is intended for tools and isn't
>>  >  inherited (making it not good for normal builds) but does apply at
>>  >  runtime. In this instance, the prerequisite is the most appropriate way
>>  >  to require the maven version.
>>  >
>>  >
>>  >  -----Original Message-----
>>  >  From: Richard van Nieuwenhoven [mailto:nir@cfc.at]
>>  >  Sent: Thursday, April 03, 2008 6:08 AM
>>  >  To: Maven Developers List
>>  >  Subject: Re: [VOTE] Release Maven Eclipse plugin version 2.5.1
>>  >
>>  >
>>  >
>>  > Hi,
>>  >
>>  >  the requireMavenVersion also applies to the runtime, but 2.0.8 is just
>>  >  required for the testing during the build. As far as i know not for the
>>  >  runtime. We use the plugin in a lot of projects that are locked to maven
>>  >  2.0.7.
>>  >
>>  >  So please limit it only for the build time.
>>  >
>>  >  regards,
>>  >  Ritchie
>>  >
>>  >
>>  >
>>  >  Jerome Lacoste wrote:
>>  >  > On Wed, Apr 2, 2008 at 11:13 AM, Arnaud HERITIER <aheritier@gmail.com>
>>  >  wrote:
>>  >  >> Hi Jerome,
>>  >  >>
>>  >  >>   As you noticed, this plugin requires to be build with maven >=
>>  >  2.0.8
>>  >  >>  because of some tests with encodings.
>>  >  >>   I'll add an enforcer rule as Benjamin proposed.
>>  >  >
>>  >  > I had added a patch to the issue  hat uses the inbbuild POM
>>  >  > requireMavenVersion instead of using the enforcer plugin. That worked
>>  >  > for me.
>>  >  >
>>  >  > Cheers,
>>  >  >
>>  >  > Jerome
>>  >  >
>>  >  > ---------------------------------------------------------------------
>>  >  > To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
>>  >  > For additional commands, e-mail: dev-help@maven.apache.org
>>  >  >
>>  >  >
>>  >
>>  >
>>  >  ---------------------------------------------------------------------
>>  >  To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
>>  >  For additional commands, e-mail: dev-help@maven.apache.org
>>  >
>>  >
>>  >  ---------------------------------------------------------------------
>>  >  To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
>>  >  For additional commands, e-mail: dev-help@maven.apache.org
>>  >
>>  >
>>
>>
>>
>>
>>
>> --
>>  ..........................................................
>>  Arnaud HERITIER
>>  ..........................................................
>>  OCTO Technology - aheritier AT octo DOT com
>>  www.octo.com | blog.octo.com
>>  ..........................................................
>>  ASF - aheritier AT apache DOT org
>>  www.apache.org | maven.apache.org
>>  ...........................................................
>>
>>     
>
>
>
>   


Mime
View raw message