maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: integration tests (was: [continuum] BUILD FAILURE: Integration Test Executor)
Date Sat, 03 Nov 2007 09:29:23 GMT

On 03/11/2007, at 5:25 PM, Jason van Zyl wrote:

> The core IT plugins all get installed as 2.1-SNAPSHOT (when or who  
> changed that), but that test is looking for 1.0-SNAPSHOT. I always  
> install all the plugins as part of running the ITs, and I've not  
> had that problem. That plugin is looking for 1.0-SNAPSHOT so it's  
> not going to find it.

I changed it to 2.1-SNAPSHOT a while back - mentioned on the list at  
the time, and documented in the ITProblems.txt file. I must have  
missed this one - and perhaps had not cleared the local repo out  
until after that time. Fixed - sorry about that.

> Unless we're testing snapshot and/or download functionality we  
> should probably release the test plugins.

That's still going to require downloading - either way it should be  
improved. I've already documented these in ITProblems.txt.

> Isolate the ITs for plugins that must be locally installed to test  
> local only use cases. I'll take a look tomorrow but I don't see  
> John changing any POMs. I'll take a look tomorrow as I see it0119  
> and it0089 have their artifacts going to the wrong groupId (should  
> be org.apache.maven.its).

Yeah, that's annoying - I've updated ITProblems.txt (89 should be  
moved to checkstyle anyway, and 119 is testing plugin prefix order  
but should just an alternate settings.xml file).

Anyway, should be working again now.

Thanks,
- Brett


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message