maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Lundberg <denn...@apache.org>
Subject Re: svn commit: r591980 - /maven/enforcer/trunk/maven-enforcer-plugin/pom.xml
Date Mon, 05 Nov 2007 16:05:08 GMT
Brian,

If you have a prereq of maven 2.0.6, can you still use maven-core:2.0.7?

brianf@apache.org wrote:
> Author: brianf
> Date: Mon Nov  5 04:52:04 2007
> New Revision: 591980
> 
> URL: http://svn.apache.org/viewvc?rev=591980&view=rev
> Log:
> encoding changes require new p:u and thus maven > 2.0.6
> 
> Modified:
>     maven/enforcer/trunk/maven-enforcer-plugin/pom.xml
> 
> Modified: maven/enforcer/trunk/maven-enforcer-plugin/pom.xml
> URL: http://svn.apache.org/viewvc/maven/enforcer/trunk/maven-enforcer-plugin/pom.xml?rev=591980&r1=591979&r2=591980&view=diff
> ==============================================================================
> --- maven/enforcer/trunk/maven-enforcer-plugin/pom.xml (original)
> +++ maven/enforcer/trunk/maven-enforcer-plugin/pom.xml Mon Nov  5 04:52:04 2007
> @@ -34,6 +34,12 @@
>  		<system>JIRA</system>
>  		<url>http://jira.codehaus.org/browse/MENFORCER</url>
>  	</issueManagement> 
> +    
> +	<prerequisites>
> +   	   <!--because of the encoding fixes, I need a new plexus-utils. The new plexus
utils can only be used in 2.0.6 or later: http://jira.codehaus.org/browse/MNG-2892 -->
> +	   <maven>2.0.6</maven>
> +    </prerequisites>
> +	
>  	<developers>
>  		<developer>
>  			<id>brianf</id>
> @@ -94,27 +100,27 @@
>  		<dependency>
>  			<groupId>org.apache.maven</groupId>
>  			<artifactId>maven-artifact</artifactId>
> -			<version>2.0.5</version>
> +			<version>2.0.7</version>
>  		</dependency>
>  		<dependency>
>  			<groupId>org.apache.maven</groupId>
>  			<artifactId>maven-plugin-api</artifactId>
> -			<version>2.0.5</version>
> +			<version>2.0.7</version>
>  		</dependency>
>  		<dependency>
>  			<groupId>org.apache.maven</groupId>
>  			<artifactId>maven-project</artifactId>
> -			<version>2.0.5</version>
> +			<version>2.0.7</version>
>  		</dependency>
>  		<dependency>
>  			<groupId>org.apache.maven</groupId>
>  			<artifactId>maven-core</artifactId>
> -			<version>2.0.5</version>
> +			<version>2.0.7</version>
>  		</dependency>
>  		<dependency>
>  			<groupId>org.codehaus.plexus</groupId>
>  			<artifactId>plexus-utils</artifactId>
> -			<version>1.4.2</version>
> +			<version>1.4.6</version>
>  		</dependency>
>          <dependency>
>              <groupId>commons-lang</groupId>
> 
> 
> 


-- 
Dennis Lundberg

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message