maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phil Steitz" <>
Subject Re: [poll] Requiring users to specify plugin versions in Maven 2.1 or later
Date Tue, 04 Sep 2007 04:59:06 GMT
On 9/3/07, Jason Dillon <> wrote:
> A
> I think this is *critical* to reduce build fragility which is
> currently affects many/most Maven 2 builds.

+1 for reducing build fragility, however we can do it

> IMO, making the version required, just like it is for dependencies is
> a bit of a burden, but will dramatically increase the build longevity
> of Maven 2 projects.

I don't claim to understand all of the ins and outs of how plugin
dependencies work and what the realistic options are to cleanup the
mess that indeterminacy has caused; but at least at apache, we have to
have our builds reproducible - reliably, durably, from tags and
released sources.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message