maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cédric Vidal <c.vi...@proxiad.com>
Subject RE: Attached artifacts in reactor mode
Date Thu, 16 Aug 2007 16:11:31 GMT
Hi John,

Hey hey indeed, I overlooked the uber-jar, I assumed the maven components
were resolved dynamically at runtime, it's way more clear now ;)

Maybe the instructions could be improved by mentioning what you just told
me, something like the following at the end of chapter "Building Maven 2.0
with Maven installed" in the "Building Maven" document:

"Note that if you want to modify one or more core components, you need to
re-build the assembly (all of the components collapsed into one, basically)
and re-install it to M2_HOME in order for your changes to be taken into
account. It's not enough to simply install the new version of maven-artifact
into the local repository."

Thanx!

Regards,

Cédric
 
-----Message d'origine-----
De : John Casey [mailto:jdcasey@commonjava.org] 
Envoyé : jeudi 16 août 2007 16:02
À : Maven Developers List
Objet : Re: Attached artifacts in reactor mode

Unfortunately, since the maven distribution uses an uber-jar (all of  
the sub-jars collapsed into one, basically), you'll need to re- 
boostrap like you did originally. It's not enough to simply install  
the new version of maven-artifact into the local repository.

Sorry for any confusion. If the instructions in that document are  
wrong or misleading, we'd love to get your notes on how to improve them.

Thanks,

-john

On Aug 15, 2007, at 5:54 PM, Cédric Vidal wrote:

> Hi guys,
>
>
>
> I’m studying the problem of attached artifact resolving in reactor  
> mode
> mentionned in MNG-2398. I’m affected by this issue and am trying to  
> see if I
> could find a working solution but I have difficulties getting
> maven-2.0.8-SNAPSHOT set up. I have checked out trunks as mentioned in
> http://maven.apache.org/guides/development/guide-building-m2.html,  
> executed
> “maven install” in trunks/maven-2.0.x/, made an assembly, installed  
> it and
> made it the active maven instance of my machine.
>
>
>
> I have imported the sources in a eclipse, made some changes to
> maven-artifact, but when I run maven package on the test project  
> attached to
> MNG-2398, maven always picks up an old version of maven-artifact  
> (according
> to the –X output) but not my freshly build maven-artifact-2.0.8- 
> SNAPSHOT.
>
>
>
> I was assuming, the maven components version would be picked up  
> according to
> the version of the maven-core, but it seems more complicated than  
> that.
>
>
>
> How can I make maven use maven-artifact-2.0.8-SNAPSHOT (and other
> 2.0.8-SNAPSHOT components artefact of course)?
>
>
>
> Cheers,
>
>
>
> Cédric VIDAL
>
> ProxiAD Ile de France
> 12, rue Chaussée d'Antin
>
> 75 009 PARIS
> Portable : 06 63 58 71 40
> Téléphone : 01 49 49 05 30
> Adresse électronique :  <mailto:c.vidal@proxiad.com>  
> c.vidal@proxiad.com
>
>
>

---
John Casey
Committer and PMC Member, Apache Maven
mail: jdcasey at commonjava dot org
blog: http://www.ejlife.net/blogs/john




---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message