maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cédric Vidal <c.vi...@proxiad.com>
Subject Attached artifacts in reactor mode
Date Wed, 15 Aug 2007 21:54:29 GMT
Hi guys,

 

I’m studying the problem of attached artifact resolving in reactor mode
mentionned in MNG-2398. I’m affected by this issue and am trying to see if I
could find a working solution but I have difficulties getting
maven-2.0.8-SNAPSHOT set up. I have checked out trunks as mentioned in
http://maven.apache.org/guides/development/guide-building-m2.html, executed
“maven install” in trunks/maven-2.0.x/, made an assembly, installed it and
made it the active maven instance of my machine.

 

I have imported the sources in a eclipse, made some changes to
maven-artifact, but when I run maven package on the test project attached to
MNG-2398, maven always picks up an old version of maven-artifact (according
to the –X output) but not my freshly build maven-artifact-2.0.8-SNAPSHOT.

 

I was assuming, the maven components version would be picked up according to
the version of the maven-core, but it seems more complicated than that.

 

How can I make maven use maven-artifact-2.0.8-SNAPSHOT (and other
2.0.8-SNAPSHOT components artefact of course)?

 

Cheers,

 

Cédric VIDAL

ProxiAD Ile de France
12, rue Chaussée d'Antin

75 009 PARIS
Portable : 06 63 58 71 40
Téléphone : 01 49 49 05 30
Adresse électronique :  <mailto:c.vidal@proxiad.com> c.vidal@proxiad.com

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message