maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephane Nicoll" <stephane.nic...@gmail.com>
Subject Re: maven-install-plugin :: Cannot override read-only parameter: artifactId ?
Date Tue, 01 May 2007 08:09:35 GMT
On 5/1/07, jbonevich <jbonevich@compendiabio.com> wrote:
>
> I can confirm that a download of the source from svn and building a snapshot
> locally does the trick.
>
> Please, oh, please, maven-lords that be!  Please, deploy a new snapshot of
> 2.2 - the one on the snapshot site is almost a year old now.  Thanx!

Done. We can also release it if there is no more pending issues. I'll
have a look.

Cheers,
St├ęphane
>
> jeff
>
>
>
> Jason Dillon wrote:
> >
> > Aighty I figured this out... the tag for maven-install-plugin-2.1 has
> > groupId, artifactId, version, packaging and file all marked with
> > '@readonly'.  The latest trunk of maven-install-plugin does not have
> > these tags.
> >
> > So, with 2.1 you can only `mvn install:install-file` from the command-
> > line, and can not use the install-file goal from an execution.
> >
> > We need to get 2.2 released.
> >
> >   * * *
> >
> > This worked for me before because I had built 2.2-SNAPSHOT locally
> > (to test my forceVersion patch) and mvn decided to pick that up...
> > not sure why though.  Why would mvn pick up a locally built SNAPSHOT
> > and use that instead of the released 2.1?  I don't like the magical
> > RELEASE stuff anyways... but I'd not expect that when a <version> for
> > a plugin is omitted that mvn would pick up a non-release to use
> > instead if it finds one in my repo cache.
> >
> > --jason
> >
> >
> > On Apr 2, 2007, at 4:44 PM, Brett Porter wrote:
> >
> >> I thought that had always been the case and was a known issue in
> >> the install plugin.
> >>
> >> On 03/04/2007, at 6:32 AM, Jason Dillon wrote:
> >>
> >>> I all of a sudden started to see this today:
> >>>
> >>> <snip>
> >>> [INFO]
> >>> ---------------------------------------------------------------------
> >>> ---
> >>> [ERROR] BUILD ERROR
> >>> [INFO]
> >>> ---------------------------------------------------------------------
> >>> ---
> >>> [INFO] Error configuring: org.apache.maven.plugins:maven-install-
> >>> plugin. Reason: ERROR: Cannot override read-only parameter:
> >>> artifactId in goal: install:install-file
> >>> </snip>
> >>>
> >>> From what I can tell this is using maven-install-plugin 2.1.
> >>>
> >>> Anyone know whats going on?  I get the same problem with Maven
> >>> 2.0.5 and 2.0.6 :-(
> >>>
> >>> --jason
> >>>
> >>> ---------------------------------------------------------------------
> >>> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> >>> For additional commands, e-mail: dev-help@maven.apache.org
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> >> For additional commands, e-mail: dev-help@maven.apache.org
> >>
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> > For additional commands, e-mail: dev-help@maven.apache.org
> >
> >
> >
>
> --
> View this message in context: http://www.nabble.com/maven-install-plugin-%3A%3A-Cannot-override-read-only-parameter%3A-artifactId---tf3508089s177.html#a10263145
> Sent from the Maven Developers mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message