maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian E. Fox" <bri...@reply.infinity.nu>
Subject RE: [VOTE] MINSTALL-37 WAS forceVersion for maven-install-plugin?
Date Thu, 03 May 2007 02:09:58 GMT

>Its not really that close to install:install-file, since  
>install:install deals with attached artifacts as well as the primary  
>artifact.  To get the same affect with install:install-file with a  
>project which has many attached artifacts, then you'd need to  
>configure an execute of install:install-file per artifact.  Much  
>easier to simply have one execution with a forceVersion set IMO.

Thanks for pointing that out, I hadn't considered that.

>I guess I don't really care too much, and if I do start caring, then  
>I will just fork this plugin.  Though really I don't see how adding a  
>little bit of flexibility to this plugin really hurts anyone.

Normally I agree, (take a look at all the params in mdep) however given
that this is a core plugin, changes to these goals are nearly equivalent
to new features of maven itself. I think it deserves a closer look,
that's all.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message