maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Max Bowsher <ma...@ukf.net>
Subject Re: Regression: (was: [ANN] Maven 2.0.6 Released)
Date Mon, 02 Apr 2007 15:47:13 GMT
Jörg Schaible wrote:
> Another regression problem: XDoclet plugin is completly broken. The
> plugin itself was problematic anyway, since it depends on the
> o.a.m.p:maven-anrun-plugin:1.0 (as jar dependency!!!) that prevented the
> version 1.1 from antrun-plugin to work properly already with earlier
> Maven versions (MOJO-641). IIRC for M206 was something done with the
> classpaths of plugins in general ... and now the xdoclet-maven-plugin
> chokes directly (MOJO-618 - I don't know why ther OP did close this
> issue though, he clearly states himself that it's broken for M206).

xdoclet-maven-plugin is working fine for me with Maven 2.0.6.

The error in MOJO-618 looks like a dependency misresolution - it's using
ant-1.5.2 with ant-launcher-1.6.5. I've seen this happen with Maven
2.0.5, with POMs that add plugin dependencies (e.g., to add additional
ant tasks).

Max.



Mime
View raw message