maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jesse McConnell" <jesse.mcconn...@gmail.com>
Subject Re: [RANT] This Maven thing is killing us....
Date Wed, 05 Jul 2006 16:54:58 GMT
yep, totally...its just that 3.7 should never be 'fuzzy' from a
dependency standpoint unless it is 3.7-SNAPSHOT or this new idea of
incrementing pom versions for same jar.

in freebsd versioning this would be equivalent to something like
treating this 3.7-1 deal as 3.7-STABLE which could be treated just
like the -SNAPSHOT.  Difference being that 3.7-STABLE refers to the
evolution of metadata surrounding tne 3.7 release whereas -SNAPSHOT
refers to evolution of the underlying code.

jesse

On 7/5/06, Mark Hobson <markhobson@gmail.com> wrote:
> On 05/07/06, Jesse McConnell <jesse.mcconnell@gmail.com> wrote:
> > might be better off using the version ranges notation for this kind of
> > thing, I don't think you want to get into the habit of x.y being some
> > kinda fuzzy defintion, it should refer to a specific version.
> >
> > [3.7,) or something along those lines...
> >
> > http://docs.codehaus.org/display/MAVEN/Dependency+Mediation+and+Conflict+Resolution
> >
> > then when it comes to your release time, pin it down to a specific
> > version of the pom for release
>
> I did think of ranges, but even atm 3.7 is just a 'soft' version -
> merely a recommendation.  This notion could be extended to accommodate
> the above, with it becoming the 'hard' version [3.7-1] at release
> time.
>
> Mark
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
>
>


-- 
jesse mcconnell
jesseDOTmcconnellATgmailDOTcom

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message