maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <Joerg.Schai...@Elsag-Solutions.com>
Subject RE: [discuss] Java 5
Date Fri, 07 Jul 2006 10:22:34 GMT
Andrew Williams wrote on Friday, July 07, 2006 12:16 PM:

> -1 We have to support 1.4 as we a re rolling into academic
> environments where the upgrade cycle is > 3 years, so many users are
> still 
> new to 1.4
> (though they do not know it). And to be honest I just don't trust 1.5
> generating 1.4 code... 

Well, when Sun released 1.5 they also proposed, that a new JDK version will now follow every
year (and Sun will phase out the support for the old ones therefore much earlier). If they
really mange to do so, you will get really out of sync. Meanwhile even some of our customers
of the financial business realized this and they already start to upgrade (although they are
traditionally *very* conservative).

- Jörg

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message