maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <Joerg.Schai...@Elsag-Solutions.com>
Subject RE: [RANT] This Maven thing is killing us....
Date Fri, 07 Jul 2006 06:58:51 GMT
Hi Brett,

Brett Porter wrote on Friday, July 07, 2006 8:49 AM:

> On 6/07/2006 3:40 AM, Rinku wrote:
[snip]
>> The other thing is that when an artifact is published to a repo, the
>> publisher can add some compatibility meta-data as well to indicate
>> that the current version is incompatible with certain other versions
>> or the artifacts.
> 
> Yes, this would be a good addition to 2.1 - I think it is
> already in the
> wiki (but should be added if not).
> 
> This would only need to affect open-upper-ended ranges (including soft
> versions). So for junit, if we assumed 4.0 was not compatible with <
> 4.0, ranges would change like this:
> 
> [3.8,) --> [3.8,4.0)
> [3.8,4.1] --> unchanged (the range explicitly allows the
> incompatibility, maybe a warning)
> (,5.0] --> unchanged (the range explicitly allows the incompatibility,
> maybe a warning)
> 3.8 --> (,4.0) (suggest 3.8)
> 
> Then the normal logic could kick in.

You may also have the need to exclude a version in that range because of a critical bug. E.g.
proxytoys run with CGLIB 2.0, 2.0.2 and 2.1.x ... but not with 2.0.1, that one had introduced
a major bug, that broke proxytoys.

- Jörg

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message