maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: [RANT] This Maven thing is killing us....
Date Fri, 07 Jul 2006 07:06:11 GMT
On 7/07/2006 4:58 PM, Jörg Schaible wrote:
> You may also have the need to exclude a version in that range because of a critical bug.
E.g. proxytoys run with CGLIB 2.0, 2.0.2 and 2.1.x ... but not with 2.0.1, that one had introduced
a major bug, that broke proxytoys.

you can already do that from the dependees end:
[2.0],[2.0.2,) or [2.0],[2.0.2],[2.1,) depending on if 2.0.3 <= x < 2.1 
are any good.

 From a releasers end, I'm inclined to say they should pull the release, 
but since some people may have already gotten it metadata that says 
"this release is totally broken" that warns new users might be better.

- Brett

-- 
Apache Maven - http://maven.apache.org/
Better Builds with Maven - http://library.mergere.com/

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message