maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: [discuss] Java 5
Date Fri, 07 Jul 2006 07:02:58 GMT
On 7/07/2006 4:51 PM, Milos Kleint wrote:
> I think I can forbid installing the netbeans modules when running on
> 1.4. My concern was how the 1.4-compiled netbeans binaries will play
> with the 1.5-compiled binaries of mevenide. (or if I compile mevenide
> with 1.4, how wil it play with 1.5-compiled maven embedder.) Anyone
> has experience with such a setup?

Right... it would only matter if the embedder forced you to use 1.5 
features yourself which I don't see happening for a while (changing the 
requirement still takes a while for it to filter through the API).

Another alternative might be some sort of little bootstrapper/verifier 
thing that could check the java.version system property before 
attempting to run the other.

Anyway, no need to rush into this - something to keep in the back of our 
minds if we decide it's worthwhile doing and then can go and investigate 
all the consequences :)

Thanks,
Brett

-- 
Apache Maven - http://maven.apache.org/
Better Builds with Maven - http://library.mergere.com/

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message