maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Iulia Andreescu" <iulia.andree...@aikitechnologies.com>
Subject XML test reports problem
Date Fri, 09 Jun 2006 10:01:17 GMT
Hi,
 
Could you please help me with this problem? I have started to study
Maven a few weeks ago and I have found what I think it is a bug in
generating the xml test reports: if I have 2 test classes A and B, in
the xml test report for class A all the test methods from both class A
and B are displayed.
 
More precisely, the steps I took were the following:
1) I created the maven project:
mvn archetype:create -DgroupId=com.mycompany.app -DartifactId=my-app
2) I created a new test class in the same package as the one generated
by Maven (in fact it was a copy paste; I replaced the class name from
AppTest to App2Test)
 
3) mvn test
 
The result is in the TEST-com.mycompany.app.App2Test.xml file, the tests
from both AppTest and App2Test classes are put:
 
-
<file:///D:/Temp/MavenTest/my-app/target/surefire-reports/TEST-com.mycom
pany.app.App2Test.xml#>  <testsuite errors="0" skipped="0" tests="1"
time="0" failures="0" name="com.mycompany.app.App2Test">
..............................
  <testcase time="0" name="testApp" /> 
  <testcase time="0" name="test2App" /> 
  </testsuite>
 
 
    Is this a known bug or I'm doing something wrong? Any help is
appreciated.
 
    Thank you,
    Iulia
 
 
 
 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message