maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Lundberg <denn...@apache.org>
Subject Re: [vote] [m1] release xdoc-plugin-1.10
Date Mon, 12 Jun 2006 21:18:33 GMT
Lukas Theussl wrote:
> Thanks Dennis! See my comments in-line.
> 
> 
>> - There is no longer a pdf.gif file under /images/. 
> 
> This was deleted by Arnaud in rev 386905 
> (http://svn.apache.org/viewvc?view=rev&revision=386905), and moved to 
> the pdf plugin. Is there an issue with that?

Nope, no problem. Just something I noticed that's all.

>> - The "Downloads" link always shows up in the left hand navbar.
> 
> I built the beanutils page myself and I do not see the Download link. 
> This link is only generated when the property 
> 'maven.xdoc.distributionUrl' is defined, however, I don't think this 
> behavior has changed since xdoc-1.9.2.

Beanutils has a dependency on maven-xdoc-plugin 1.9.2 so you need to 
either change the version to 1.10-SNAPSHOT or remove the dependency. I 
forgot to mention that.

I just did a "maven clean site" and I still get the "Downloads" link 
when building it using the 1.10-SNAPSHOT version.

I read about the property in the docs. Beanutils does not have that 
property though.

>> - On some components [beanutils] the title is missing "Downloads" 
>> after the project name, on the downloads page.
>>
>> - On some components [beanutils] the title is missing "Source 
>> repository" after the project name, on the scm-usage page.
> 
> Do you have a component where there is a title? - I don't see one 
> anywhere, but you have that problem already on your current site (eg 
> http://jakarta.apache.org/commons/beanutils/dependencies.html) which was 
> built with xdoc-plugin-1.9.2 (I presume). It's due to an issue with your 
> custom site.jsl (commons-site.jsl) file, it doesn't take into account 
> that the standart Maven-generated pages are fully internationalized. I'd 
> have to take a closer look to see how to fix it, but anyway, this is not 
> an issue caused by xdoc-plugin-1.10.

Commons email has the title.

You might be right on track about the jsl file. The component sites that 
work properly have a "new and improved" way of applying the jsl file. So 
it's probably something wrong with the old way. I'll dig into it and see 
if I can find out why it happens.

>> - The "Development process" link in the navbar now goes to a generated 
>> page, which contains a link, instead of going to the url directly.
> 
> See http://jira.codehaus.org/browse/MPXDOC-170, apparently I forgot to 
> add it to the changes.xml file. Will do.

That explains it.

>> - The file rename from cvs-usage to scm-usage will mean some work for 
>> us, but the change is well documented and it is "the right thing" to do.
> 
> 
> :)
> 
> You didn't cast a vote but IMO these are all non-blocking issues (if 
> issues at all), so I take it that we can go ahead with the release?

Oh, sorry! I forgot that I am supposed to vote now :)

If the Downloads link problem above and another problem I found (will 
send another mail about that) can be solved, I'm +1. The rest seems to 
be Commons specific, which shouldn't hold back the release of the xdoc 
plugin.

> Thanks again for the testing and the feedback,
> 
> -Lukas
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
> 


-- 
Dennis Lundberg

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message