maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roland Klein (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (MNGECLIPSE-27) Problems editing pom.xml by hand
Date Fri, 13 Jan 2006 10:53:03 GMT
     [ http://jira.codehaus.org/browse/MNGECLIPSE-27?page=all ]
     
Roland Klein closed MNGECLIPSE-27:
----------------------------------

    Resolution: Won't Fix

Hello Eugene,

i tested the latest revision (rev.14) with eclipse 3.1 and 3.2M4 in both enviroments all works
fine.
But than i changed the Embedder to maven-embedder-2.0.1-dep.jar and then MavenEmbedder finds
a duplicate projectId in my pom.xml.

To make it short, the distribution in svn works, so i close this issue.

Roland

> Problems editing pom.xml by hand
> --------------------------------
>
>          Key: MNGECLIPSE-27
>          URL: http://jira.codehaus.org/browse/MNGECLIPSE-27
>      Project: Maven 2.x Plug-in for Eclipse
>         Type: Bug

>     Versions: 0.0.3
>  Environment: WIN2K, Eclipse3.1, m2eclipse 0.0.3 (rev8 2006-01-03), maven-embedder-2.0.1-dep.jar
>     Reporter: Roland Klein
>     Assignee: Eugene Kuleshov
>      Fix For: 0.0.4

>
>
> If you edit pom.xml by hand, then several calls to Maven2Builder.build() take place.
 And in this method the call to Maven2Plugin.getDefault().resolveClasspathEntries() after
the first time return an empty entries array.
>    - i inserted in Maven2Plugin:360 a call to resetMavenEmbedder(); This is not the preserving
resources and maybe there is better way to tell MavenEmbedder to reset, because the call resetMavenEmbedder()
results in instatiating a new MavenEmbedder ;-(
>    - now everytime a call to Maven2Builder.build() suceeds and the entries array is filled
up correctly, 
>      but in the eclipse package explorer the libs are shown directly under the project
and not under the 
> 	 ClasspathContainer and no description of the Container is shown. The build suceeds
too and all 
> 	 dependencies are resolved correctly. If i close the project and the second instance
of eclipse and 
> 	 then reopen both, everything works fine classpathEntries are shown under ClasspathContainer
and so on. Any ideas?

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message