maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Lundberg <dennis.lundb...@mdh.se>
Subject Re: [m2] Problem having the parent on the same level as the children using the site-plugin
Date Wed, 11 Jan 2006 20:49:52 GMT
Brett Porter wrote:
> I agree, and I don't underestand why it fails in the parent (I
> understand why it would impact the children and it should be used in any
> case).
> 
> Can you drop that test case into JIRA?

Will do that.

-- 
Dennis Lundberg

> 
> Dennis Lundberg wrote:
>> I did not have <relativePath/> set at all. If I set that in module-1 a
>> link from the parent site to module-1 shows up in the menu. So that
>> solved my problem, thanks.
>>
>> However I'm a bit confused as to why this is needed. The parent has all
>> the knowledge it needs about the children from the <modules/> section in
>> the parent's pom. The reason for putting a <relativePath/> in a child
>> would so that the child would know about its parent, like for creating a
>> link from the child to the parent. IMHO the rendering of the parent site
>> should not need <relativePath/> in its children to be able to create
>> links to the child sites.
>>
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message