maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eugene Kuleshov (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MNGECLIPSE-20) using ${version} for subproject dependencies doesn't work (maven uses 2.4.1 version instead)
Date Fri, 20 Jan 2006 08:36:06 GMT
    [ http://jira.codehaus.org/browse/MNGECLIPSE-20?page=comments#action_56441 ] 

Eugene Kuleshov commented on MNGECLIPSE-20:
-------------------------------------------

Jason, this is happening with 2.0.2 embedder. The strange thing that execute install from
the embedder is working fine, but readProjectWithDependencies() is pulling off version "2.4.1"
out of nowhere.

> using ${version} for subproject dependencies doesn't work (maven uses 2.4.1 version instead)
> --------------------------------------------------------------------------------------------
>
>          Key: MNGECLIPSE-20
>          URL: http://jira.codehaus.org/browse/MNGECLIPSE-20
>      Project: Maven 2.x Plug-in for Eclipse
>         Type: Bug

>     Versions: 0.0.3
>  Environment: win xp, maven 2.0.1, eclipse plugin 0.0.3, eclipse 3.1
>     Reporter: Michal Stochmialek
>     Assignee: Jason van Zyl
>      Fix For: 0.0.4
>  Attachments: mvn-multiproject.zip
>
>
> My project is a ear multiproject. It has 5 modules, that have internal dependencies.
For example web module needs app and type modules. 
> I usually use following declaration for this kind of dependencies. Note that I'm using
${version} in dependency. In result I'm requesting foo-type jar of the same version as current
project.
> <project>
>   <modelVersion>4.0.0</modelVersion>
>   <parent>
>     <groupId>foo</groupId>
>     <artifactId>foo</artifactId>
>     <version>0.0.1-SNAPSHOT</version>
>   </parent>
>   <artifactId>foo-app</artifactId>
>   <dependencies>
>     <dependency>
>       <groupId>foo</groupId>
>       <artifactId>foo-type</artifactId>
>       <version>${version}</version>
>     </dependency>
>   </dependencies>
> </project>
> This works from commandline, but doesn't work in eclipse plugin. I get following message:
> "Unable to download the artifact from any repository foo:foo-type-2.4.1.jar"
> Maven (or maven plugin) tries to download foo-type module in very strange version (instead
0.0.1-SNAPSHOT)! 
> I've attached simple multimodule project.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message