maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carlos Sanchez (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MEV-295) dom4j optional dependencies
Date Wed, 18 Jan 2006 23:05:40 GMT
    [ http://jira.codehaus.org/browse/MEV-295?page=comments#action_56267 ] 

Carlos Sanchez commented on MEV-295:
------------------------------------

it's fine, please apply

> dom4j optional dependencies
> ---------------------------
>
>          Key: MEV-295
>          URL: http://jira.codehaus.org/browse/MEV-295
>      Project: Maven Evangelism
>         Type: Task

>     Reporter: fabrizio giustina
>     Assignee: Edwin Punzalan
>  Attachments: MEV-295-dom4j.patch
>
>
> Most of the dependencies in dom4j should be optional
> This is the full list for dom4j 1.6.1 (the xml-apis depoendency version is fixed too):
> <dependencies>
>     <dependency>
>       <groupId>jaxme</groupId>
>       <artifactId>jaxme-api</artifactId>
>       <version>0.3</version>
>       <optional>true</optional>
>     </dependency>
>     <dependency>
>       <groupId>jaxen</groupId>
>       <artifactId>jaxen</artifactId>
>       <version>1.1-beta-4</version>
>       <optional>true</optional>
>     </dependency>
>     <dependency>
>       <groupId>msv</groupId>
>       <artifactId>xsdlib</artifactId>
>       <version>20030807</version>
>       <optional>true</optional>
>     </dependency>
>     <dependency>
>       <groupId>msv</groupId>
>       <artifactId>relaxngDatatype</artifactId>
>       <version>20030807</version>
>       <optional>true</optional>
>     </dependency>
>     <dependency>
>       <groupId>pull-parser</groupId>
>       <artifactId>pull-parser</artifactId>
>       <version>2</version>
>       <optional>true</optional>
>     </dependency>
>     <dependency>
>       <groupId>xpp3</groupId>
>       <artifactId>xpp3</artifactId>
>       <version>1.1.3.3</version>
>       <optional>true</optional>
>     </dependency>
>     <dependency>
>       <groupId>stax</groupId>
>       <artifactId>stax-api</artifactId>
>       <version>1.0</version>
>       <optional>true</optional>
>     </dependency>
>     <dependency>
>       <groupId>xml-apis</groupId>
>       <artifactId>xml-apis</artifactId>
>       <version>1.0.b2</version>
>     </dependency>
>     <dependency>
>       <groupId>junitperf</groupId>
>       <artifactId>junitperf</artifactId>
>       <version>1.8</version>
>       <scope>test</scope>
>     </dependency>
>     <dependency>
>       <groupId>stax</groupId>
>       <artifactId>stax-ri</artifactId>
>       <version>1.0</version>
>       <scope>test</scope>
>     </dependency>
>     <dependency>
>       <groupId>xerces</groupId>
>       <artifactId>xercesImpl</artifactId>
>       <version>2.6.2</version>
>       <scope>test</scope>
>     </dependency>
>     <dependency>
>       <groupId>xalan</groupId>
>       <artifactId>xalan</artifactId>
>       <version>2.5.1</version>
>       <scope>test</scope>
>     </dependency>
>   </dependencies>
> And the following is for dom4j 1.6.1:
> <dependencies>
>     <dependency>
>       <groupId>jaxme</groupId>
>       <artifactId>jaxme-api</artifactId>
>       <version>0.3</version>
>       <optional>true</optional>
>     </dependency>
>     <dependency>
>       <groupId>jaxen</groupId>
>       <artifactId>jaxen</artifactId>
>       <version>1.1-beta-6</version>
>       <optional>true</optional>
>     </dependency>
>     <dependency>
>       <groupId>msv</groupId>
>       <artifactId>xsdlib</artifactId>
>       <version>20030807</version>
>       <optional>true</optional>
>     </dependency>
>     <dependency>
>       <groupId>msv</groupId>
>       <artifactId>relaxngDatatype</artifactId>
>       <version>20030807</version>
>       <optional>true</optional>
>     </dependency>
>     <dependency>
>       <groupId>pull-parser</groupId>
>       <artifactId>pull-parser</artifactId>
>       <version>2</version>
>       <optional>true</optional>
>     </dependency>
>     <dependency>
>       <groupId>xpp3</groupId>
>       <artifactId>xpp3</artifactId>
>       <version>1.1.3.3</version>
>       <optional>true</optional>
>     </dependency>
>     <dependency>
>       <groupId>stax</groupId>
>       <artifactId>stax-api</artifactId>
>       <version>1.0</version>
>       <optional>true</optional>
>     </dependency>
>     <dependency>
>       <groupId>xml-apis</groupId>
>       <artifactId>xml-apis</artifactId>
>       <version>1.0.b2</version>
>     </dependency>
>     <dependency>
>       <groupId>junitperf</groupId>
>       <artifactId>junitperf</artifactId>
>       <version>1.8</version>
>       <scope>test</scope>
>     </dependency>
>     <dependency>
>       <groupId>stax</groupId>
>       <artifactId>stax-ri</artifactId>
>       <version>1.0</version>
>       <scope>test</scope>
>     </dependency>
>     <dependency>
>       <groupId>xerces</groupId>
>       <artifactId>xercesImpl</artifactId>
>       <version>2.6.2</version>
>       <scope>test</scope>
>     </dependency>
>     <dependency>
>       <groupId>xalan</groupId>
>       <artifactId>xalan</artifactId>
>       <version>2.5.1</version>
>       <scope>test</scope>
>     </dependency>
>   </dependencies>

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message