maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eugene Kuleshov (JIRA)" <j...@codehaus.org>
Subject [jira] Updated: (MNGECLIPSE-29) Plug-In does not run behind Proxy/Firewall (where M2 itself does)
Date Fri, 20 Jan 2006 06:42:06 GMT
     [ http://jira.codehaus.org/browse/MNGECLIPSE-29?page=all ]

Eugene Kuleshov updated MNGECLIPSE-29:
--------------------------------------

    Fix Version:     (was: 0.0.4)
                 0.0.5

> Plug-In does not run behind Proxy/Firewall (where M2 itself does)
> -----------------------------------------------------------------
>
>          Key: MNGECLIPSE-29
>          URL: http://jira.codehaus.org/browse/MNGECLIPSE-29
>      Project: Maven 2.x Plug-in for Eclipse
>         Type: Bug

>     Versions: 0.0.3
>  Environment: Windows (probably ANY behind a Proxy or Firewall)
>     Reporter: Werner Keil
>     Assignee: Dmitri Maximovich
>     Priority: Minor
>      Fix For: 0.0.5
>  Attachments: pom.xml
>
>   Time Spent: 30 minutes
>    Remaining: 0 minutes
>
> While Maven 2 on its own runs the same goal (test) from the command line without errors
the Plug-in for Eclipse fails trying to update itself or some other dependency:
> [DEBUG] Found 0 components to load on start
> [DEBUG] Building Maven user-level plugin registry from: 'C:\Documents and Settings\username\.m2\plugin-registry.xml'
> [DEBUG] Building Maven global-level settings from: 'C:\Documents and Settings\username\workspace\32\mtest\conf\settings.xml'
> [DEBUG] Building Maven user-level settings from: 'C:\Documents and Settings\username\.m2\settings.xml'
> [DEBUG] mtest:mtest:jar:1.0.1-SNAPSHOT (selected for null)
> [DEBUG]   junit:junit:jar:3.8.1 (selected for compile)
> [INFO] ----------------------------------------------------------------------------
> [INFO] Building mtest
> [INFO]    task-segment: [test]
> [INFO] ----------------------------------------------------------------------------
> [DEBUG] maven-resources-plugin: resolved to version 2.1 from repository central
> [DEBUG] Found 0 components to load on start
> [DEBUG] maven-compiler-plugin: resolved to version 2.0 from repository central
> [DEBUG] Found 0 components to load on start
> [DEBUG] maven-surefire-plugin: resolved to version 2.0 from repository central
> [DEBUG] Found 0 components to load on start
> [DEBUG] org.apache.maven.plugins:maven-resources-plugin:maven-plugin:2.1 (selected for
runtime)
> [DEBUG]   commons-io:commons-io:jar:1.0 (selected for runtime)
> [DEBUG]     junit:junit:jar:3.8.1 (selected for runtime)
> [DEBUG] Skipping disabled repository snapshots
> [DEBUG] Trying repository central
> org.apache.maven.plugin.MojoExecutionException: Error configuring plugin for execution
of 'resources:resources'.
> 	at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:399)
> 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:554)
> 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:508)
> 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:494)
> 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:307)>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
> 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:149)
> 	at org.apache.maven.embedder.MavenEmbedder.execute(MavenEmbedder.java:439)
> 	at org.apache.maven.embedder.MavenEmbedder.execute(MavenEmbedder.java:383)
> 	at org.maven.ide.eclipse.Maven2Executor.main(Maven2Executor.java:71)
> Caused by: org.apache.maven.plugin.PluginConfigurationException: Error configuring: org.apache.maven.plugins:maven-resources-plugin.
Reason: Cannot resolve plugin dependencies
> 	at org.apache.maven.plugin.DefaultPluginManager.ensurePluginContainerIsComplete(DefaultPluginManager.java:650)
> 	at org.apache.maven.plugin.DefaultPluginManager.getConfiguredMojo(DefaultPluginManager.java:541)
> 	at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:394)
> 	... 8 more
> Caused by: org.apache.maven.artifact.resolver.ArtifactResolutionException: Error transferring
file
>   org.apache.maven:maven-model:2.0:jar
> from the specified remote repositories:
>   snapshots (http://snapshots.maven.codehaus.org/maven2),
>   central (http://repo1.maven.org/maven2)
> 	at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:150)
> 	at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:64)
> 	at org.apache.maven.plugin.DefaultPluginManager.resolveCoreArtifacts(DefaultPluginManager.java:682)
> 	at org.apache.maven.plugin.DefaultPluginManager.ensurePluginContainerIsComplete(DefaultPluginManager.java:639)
> 	... 10 more
> Caused by: org.apache.maven.wagon.TransferFailedException: Error transferring file
> 	at org.apache.maven.wagon.providers.http.LightweightHttpWagon.fillInputData(LightweightHttpWagon.java:85)
> 	at org.apache.maven.wagon.StreamWagon.get(StreamWagon.java:70)
> 	at org.apache.maven.artifact.manager.DefaultWagonManager.getRemoteFile(DefaultWagonManager.java:355)
> 	at org.apache.maven.artifact.manager.DefaultWagonManager.getArtifact(DefaultWagonManager.java:270)
> 	at org.apache.maven.artifact.manager.DefaultWagonManager.getArtifact(DefaultWagonManager.java:232)
> 	at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:134)
> 	... 13 more
> Caused by: java.net.NoRouteToHostException: No route to host: connect
> 	at java.net.PlainSocketImpl.socketConnect(Native Method)
> 	at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
> 	at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
> 	at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
> 	at java.net.Socket.connect(Socket.java:507)
> 	at java.net.Socket.connect(Socket.java:457)
> 	at sun.net.NetworkClient.doConnect(NetworkClient.java:157)
> 	at sun.net.www.http.HttpClient.openServer(HttpClient.java:365)
> 	at sun.net.www.http.HttpClient.openServer(HttpClient.java:477)>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
> 	at sun.net.www.http.HttpClient.<init>(HttpClient.java:214)
> 	at sun.net.www.http.HttpClient.New(HttpClient.java:287)
> 	at sun.net.www.http.HttpClient.New(HttpClient.java:299)
> 	at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:792)
> 	at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:744)
> 	at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:669)
> 	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:913)
> 	at org.apache.maven.wagon.providers.http.LightweightHttpWagon.fillInputData(LightweightHttpWagon.java:71)
> 	... 18 more
> The proxy is correctly set in 'C:\Documents and Settings\username\.m2\settings.xml',
but the plug-in does not seem to load it the same way, M2 (the Batch-launched class) does?
> Unchecking all "Update" options in the  Preferences and even setting it to "Offline"
do not change this behaviour.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message