maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: [m2] Tests are not being run
Date Thu, 21 Apr 2005 04:06:38 GMT
I've confirmed this is a problem with m2 alpha-1, but it works
consistently with CVS HEAD. No idea what was fixed, though...

Dan Diephouse wrote:

> I can't get M2 to run tests for me as of late. For instance, observe
> the output from modello-core below.  No tests are run, but there are a
> lot of test cases in src/test/java. Any ideas on why its no longer
> picking up test cases?
>
> - Dan
>
> Dan@DELL /workspace/modello/modello-core
> $ m2 install
> [INFO] modello: using locally installed snapshot
> [INFO]
> ----------------------------------------------------------------------------
>
> [INFO] Building Modello Core
> [INFO]
> ----------------------------------------------------------------------------
>
> [INFO] [resources:resources]
> [INFO] modello-test: using locally installed snapshot
> [INFO] [compiler:compile]
> [INFO] Nothing to compile - all classes are up to date
> [INFO] [resources:testResources]
> [INFO] [compiler:testCompile]
> [INFO] Nothing to compile - all classes are up to date
> [INFO] [surefire:test]
> [INFO] Setting reports dir:
> c:\eclipse\workspace\modello\modello-core\target/surefire-reports
>
> -------------------------------------------------------
> T E S T S
> -------------------------------------------------------
>
> Results :
> [surefire] Tests run: 0, Failures: 0, Errors: 0
>
> [INFO] [jar:jar]
> [INFO] Building jar:
> c:\eclipse\workspace\modello\modello-core\target\modello-core-1.0-alpha-2-SNAPSHOT.jar
>
> [INFO] [install:install]
> [INFO] Installing
> c:\eclipse\workspace\modello\modello-core\target\modello-core-1.0-alpha-2-SNAPSHOT.jar
> to c:\Documents
> and
> Settings\Dan\.m2\repository\org\codehaus\modello\modello-core\1.0-alpha-2-SNAPSHOT\modello-core-1.0-alpha-2-SNAPSHO
>
> T.jar
> [INFO]
> ----------------------------------------------------------------------------
>
> [INFO] BUILD SUCCESSFUL
> [INFO]
> ----------------------------------------------------------------------------
>
> [INFO] Total time: 1 seconds
> [INFO] Finished at: Wed Apr 20 13:36:35 EDT 2005
> [INFO] Final Memory: 1M/2M
> [INFO]
> ----------------------------------------------------------------------------
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message