maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arnaud HERITIER <aherit...@gmail.com>
Subject Re: [jira] Commented: (MPXDOC-128) Internationalized Websites
Date Thu, 28 Apr 2005 16:48:15 GMT
I'll try to publish a SNAPSHOT with the multi-locales xdoc plugin this WE.

Arnaud

On 4/28/05, Vincent Siveton <vincent.siveton@gmail.com> wrote:
> Hi again,
> 
> > 1.
> > Will Maven 2 follow an approach to I18N - will MPXDOC-128 be the solution ?
> 
> AFAIK M2 will provide i18n directly in the POM.
> The site plugin will generate the website and the reports in different
> languages.
> 
> >
> > 2.
> > Can you provide a clean snapshot hat can be used as Jump-Start into using it ? 
With an example that works on Linux  - one which we can just INSTALL and  RUN THE XDOCS-GENERATE-SITE
?
> 
> I am not a member of the xdoc team so I cant
> 
> > Thanks for you suggestions above - However...My SysAdmin also changed with the project.xml
to point to the correct model. He downloaded the Model, but this is not the problem we are
having.
> >
> > It might be of interest to you to know that we still cannot get the solution to
work on Linux:
> >
> > Maven can BUILD the project, but it seems that the text variables (property files)
cannot be found. Unresolved variables are displayed as "??variable name??" -
> 
> Its a known limitation for multiproject goal (classloader prob for the reactor)
> Actually, I have no clue about it. Let's see my post:
> http://www.mail-archive.com/dev@maven.apache.org/msg21646.html
> 
> > We followed the user instructions, we named the property files correctly, we have
them both in the /temp/ of xdocs and in the root of our /docs/ directory. We could not even
get your sample to work.
> 
> Well... lets try to update the \maven-xdoc-plugin-1.9-SNAPSHOT\plugin.jelly:
> Comment the deleted task around the line 748 (from the patch in the
> MPXDOC-128 web page)
> 
> > Well, I am a bit ashamed to admit: I made a quick-and-dirty installation of the
snapshot in my Windows system (without the project.xml, build.properties and the like... which
I assumed only important to build the snapshot... )  and it works.
> >
> > I tried to convince my Sysadmin to do the same, but .... I am also having communication
problem now - My sysadmin wants to follow a clean official procedure and wants to install
the complete snapshot.
> 
> Sorry, I can't help with corporate policies!
> 
> > (See above: Question 2)
> >
> > My respect and thanks
> >
> 
> Regards,
> 
> Vincent
> 
> > Valerie
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
> 
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message