maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arnaud HERITIER <aherit...@gmail.com>
Subject Re: cvs commit: maven-plugins maven.xml
Date Thu, 02 Sep 2004 15:35:21 GMT
I just reproduced it at work.
The problem must be due to tests :
<j:if test="${not empty(pom.build.sourceModifications)}">
and
<j:if test="${empty(pom.build.sourceModifications)}">

I modified it to recently but it worked :-(

I'll do some tests to see what happens !

Arnaud.



On Thu,  2 Sep 2004 09:57:51 -0300, Felipe Leme <maven@felipeal.net> wrote:
> On Thu, 2 Sep 2004 14:20:57 +0200, "Emmanuel Venisse" <emmanuel@venisse.net> wrote:
> 
> > It fails too for me with jdk1.4. The problem is due to the copy tag in
> > javadoc:init because the project doen't have a source directory definition
> > in the project.xml (and source files)
> 
> I think the plugin should handle this situation better, i.e., check for the existence
of such POM tag and fail with a proper message (rather than propagate the issue to the ant
call).
> 
> I can work on that fix (and a new testcase) later at home.
> 
> Felipe
> 
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> For additional commands, e-mail: dev-help@maven.apache.org
> 
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
For additional commands, e-mail: dev-help@maven.apache.org


Mime
View raw message