maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rajeev Kaul" <Raj...@customercaresolutions.com>
Subject Re: building maven plugins for 1.0 rc2
Date Fri, 19 Dec 2003 23:37:05 GMT
I found the problem.  I am using JDK 1.3.1, which probably called the
ChangeLog plugin tests to fail.  I modified the following statement:

        assertTrue(listener.getStdout().indexOf(MESSAGE)>-1);


to

       assertTrue(listener.getStdout().toString().indexOf(MESSAGE)>-1);


in the testNormalEvent() and testErrorEvent() methods.  I have attached the
modified CvsLogListenerTest.java file

Also,  I had to modify the project.xml file to include the dependency on
xml-apis and xerces libraries.

After, I made these changes the bootstrap process created all the required
plugins.

regards,

Rajeev


----- Original Message -----
From: "Jefferson K. French" <jeff@frenches.org>
To: "Maven Users List" <users@maven.apache.org>
Sent: Friday, December 19, 2003 11:23 AM
Subject: Re: building maven plugins for 1.0 rc2


> One of my co-workers had the same problem with a build he did from CVS
> a few days ago. We didn't spend too much time figuring out what was
> happening, though, because I gave him what I downloaded on 11/25, and
> all was well.
>
> Maybe you should try checking out the RC1 branch and building it.
>
>   Jeff
>
> On Fri, 19 Dec 2003, at 10:15:17 [GMT -0800] Rajeev Kaul wrote:
>
> > I downloaded the latest maven (1.0 rc2) from CVS, yesterday, and built
it using the build-bootstrap.xml file.  The build was successful.  However,
when I tried to build the plugin using the command
> > shown below, it failed.
>
>
>
> > E:\maven\maven-1.0-rc2>maven -Dgoal=clean,plugin:install
multiproject:goal
>
> >  __  __
> > |  \/  |__ _Apache__ ___
> > | |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
> > |_|  |_\__,_|\_/\___|_||_|  v. 1.1-SNAPSHOT
>
> > BUILD FAILED
> > Goal "multiproject:goal" does not exist in this project.
> > Total time: 4 seconds
> > Finished at: Fri Dec 19 10:09:27 PST 2003
>
> > E:\maven\maven-1.0-rc2>
>
>
>
>
> > The following command also fails:
>
>
>
>
> > E:\maven\maven-1.0-rc2>maven -Dgoal=clean,plugin:install,plugin:deploy
> >  __  __
> > |  \/  |__ _Apache__ ___
> > | |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
> > |_|  |_\__,_|\_/\___|_||_|  v. 1.1-SNAPSHOT
>
> > BUILD FAILED
> > Goal "jar:jar" does not exist in this project.
> > Total time: 7 seconds
> > Finished at: Fri Dec 19 10:05:53 PST 2003
>
>
>
> > Any ideas??
>
>
> > Rajeev Kaul
>
> --
> mailto:jeff@frenches.org
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org

Mime
View raw message