maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason van Zyl <ja...@zenplex.com>
Subject Re: [maven-bug] Created: (MAVEN-167) JXR plugin requires JDK 1.4
Date Sun, 01 Dec 2002 21:22:15 GMT
On Sun, 2002-12-01 at 16:29, bob@werken.com wrote:

> 
> Description:
> org.apache.maven.jxr.JxrBean uses StringBuffer.append(StringBuffer) on line 238 (last
line in getRelativeLink). That's a JDK 1.4 method, and a java.lang.NoSuchMethodError will
be thrown on inferior JDKs.
> 
> I haven't found any docs that say what JDK is required for Maven, but I would recommend
support for JDK 1.3.x for still a little while. Lots of people are still on JDK 1.3.x.
> 

I don't believe this is true. I don't use JDK 1.4 at all and the JXR
plugin works just fine.


> ---------------------------------------------------------------------
> JIRA INFORMATION:
> This message is automatically generated by JIRA.
> 
> If you think it was sent incorrectly contact one of the administrators:
>    http://jira.werken.com/Administrators.jspa
> 
> If you want more information on JIRA, or have a bug to report see:
>    http://www.atlassian.com/software/jira
> 
> 
> --
> To unsubscribe, e-mail:   <mailto:turbine-maven-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:turbine-maven-dev-help@jakarta.apache.org>
-- 
jvz.

Jason van Zyl
jason@zenplex.com
http://tambora.zenplex.org

In short, man creates for himself a new religion of a rational
and technical order to justify his work and to be justified in it.
  
  -- Jacques Ellul, The Technological Society


Mime
View raw message