maven-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Lynch" <peterly...@mindspring.com>
Subject Plugin classloader clarification
Date Tue, 03 Dec 2002 11:04:16 GMT
Hey gang,

This may be another one I am catching up on but...

Can someone offer or point me too a concise explanation as to the difference
between:

<dependency>
    <id>ant</id>
    <version>1.5</version>
    <properties>
        <classloader>root</classloader>
    </properties>
</dependency>

and:

<dependency>
    <id>ant</id>
    <version>1.5</version>
    <properties>
        <classloader>root.maven</classloader>
    </properties>
</dependency>

in a Maven plugin project.xml?

I looked at the forehead docs, but I am looking for a more Maven plugin point of
view.

If I decide that my plugin depends on Ant 1.5.1, how would the dependency be
described - as Maven itself does not load it yet? Like so, with no classloader?

<dependency>
    <id>ant</id>
    <version>1.5.1</version>
</dependency>

And then would my plugin's goals be using Ant 1.5.1 and all other goals in other
plugins in Maven use Ant 1.5?

I feeling my way back into things....thanks for any help.

-Peter


Mime
View raw message